From: Stefan Beller Date: Tue, 19 Jul 2016 19:24:36 GMT Subject: Re: [PATCH] submodule-config: use explicit empty string instead of strbuf in config_from() Message-ID: In-Reply-To: On Tue, Jul 19, 2016 at 12:15 PM, Junio C Hamano wrote: > René Scharfe writes: > >> Use a string constant instead of an empty strbuf to shorten the code >> and make it easier to read. >> >> Signed-off-by: Rene Scharfe >> --- >> ... unless someone can come up with a suitable non-empty string to feed >> to git_config_from_mem() as its name parameter. Thanks! > I wondered if we used to do something useful with rev and later that > useful thing was removed leaving an always-empty strbuf, but it > appears that this strbuf was introduced to always hold an empty > string and nothing else, which shows the (lack of) quality of > reviews in this area X-<. I am to blame for this. :( > > Will apply. Thanks.