From: Calvin Wan Date: Wed, 30 Nov 2022 19:08:09 GMT Subject: Re: [PATCH v4 4/5] diff-lib: refactor match_stat_with_submodule Message-ID: In-Reply-To: <19f91fea-a2a9-7dc6-d940-cc10f384fe76@dunelm.org.uk> > Thanks for splitting this change out. I have to say I find the original > quite a bit easier to read. If you're worried about the code added in > the next commit being too indented perhaps you could move the body of > the if statement into a separate function. Then we're just swapping if statement depth for function call depth, which seems even worse. I think the confusion comes from adding the "ret:" part which is currently unnecessary so I can get rid of that this patch. Thanks