From: Kato Kazuyoshi Date: Mon, 17 Oct 2011 01:15:07 GMT Subject: Re: [PATCH/RFC] gitweb: add the ability to show side-by-side diff on commitdiff. Message-ID: In-Reply-To: <7vobxgpixo.fsf@alter.siamese.dyndns.org> On Mon, Oct 17, 2011 at 9:20 AM, Junio C Hamano wrote: > > What are these changes for, except perhaps to make the patch larger than > necesssary to make it harder to review? > > It would leave an unnecessary SP like 'class="diff "' when all the arms of > if/elsif cascade fall off and $diff_class is left empty. It isn't a major > issue (I suspect that such a case might even be an error), and I even > think the code after the above patch would be easier to read and more > sensible, but shouldn't that kind of "style fix" be in a separate clean-up > patch that does not introduce any new feature? > Sorry. I will separate my patch into two or three commits. Probably like: - format_diff_line returns a class with an line. - remove trailing space from the class. - add side-by-side feature and CSS. - add form. Thank you for your correction! -- Kato Kazuyoshi