From: Chris Rorvick Date: Tue, 27 Nov 2012 03:00:14 GMT Subject: Re: [PATCH 1/7] push: return reject reasons via a mask Message-ID: In-Reply-To: <7vobikryrc.fsf@alter.siamese.dyndns.org> On Mon, Nov 26, 2012 at 12:43 PM, Junio C Hamano wrote: > Chris Rorvick writes: > >> Pass all rejection reasons back from transport_push(). The logic is >> simpler and more flexible with regard to providing useful feedback. >> >> Signed-off-by: Chris Rorvick >> --- > > In any case, naming it as "reject_mask" is like calling a counter as > "counter_int". It is more important to name it after its purpose > than after its type Agreed. > and because this is to record the reasons why > the push was rejected, "rejection_reason" might be a better name for > it. Yes, that is better for all the reasons you mention. I will fix this up.