From: Chris Rorvick Date: Fri, 25 Jan 2013 04:31:43 GMT Subject: Re: [PATCH v4 0/3] Finishing touches to "push" advises Message-ID: In-Reply-To: <1358978130-12216-1-git-send-email-gitster@pobox.com> On Wed, Jan 23, 2013 at 3:55 PM, Junio C Hamano wrote: > This builds on Chris Rorvick's earlier effort to forbid unforced > updates to refs/tags/ hierarchy and giving sensible error and advise > messages for that case (we are not rejecting such a push due to fast > forwardness, and suggesting to fetch and integrate before pushing > again does not make sense). FWIW, these changes look good to me. The logic in set_ref_status_for_push() is easier to follow and the additional error statuses (and associated advice) make things much clearer. Had I written the the "already exists" advice in the context of these additional statuses I would have said "the destination *tag* reference already exists", or maybe even just "the destination *tag* already exists". It's probably fine the way it is, but I only avoided using "tag" in the advice because I was abusing it. Thanks, Chris