From: Duy Nguyen Date: Sat, 15 Aug 2015 09:05:27 GMT Subject: Re: [PATCH 0/17] removing questionable uses of git_path Message-ID: In-Reply-To: <20150810092731.GA9027@sigill.intra.peff.net> On Mon, Aug 10, 2015 at 4:27 PM, Jeff King wrote: > The problem is that git_path uses a static buffer that gets overwritten > by subsequent calls. resolve_ref() was in the same boat, then we renamed it to resolve_ref_unsafe(), I believe with an intention to eventually kill it. But it lives on anyway. I wanted to suggest renaming git_path() to git_path_unsafe(). But I'm not sure if that will catch reviewer's eyes when new call sites are added. Probably not.. -- Duy