From: Nguyen Thai Ngoc Duy Date: Sat, 15 Oct 2011 00:51:15 GMT Subject: Re: [PATCHv3] daemon: give friendlier error messages to clients Message-ID: In-Reply-To: <20111014211921.GB16429@sigill.intra.peff.net> On Sat, Oct 15, 2011 at 8:19 AM, Jeff King wrote: > @@ -257,11 +266,11 @@ static int run_service(char *dir, struct daemon_service *service) >        if (!enabled && !service->overridable) { >                logerror("'%s': service not enabled.", service->name); >                errno = EACCES; > -               return -1; > +               return daemon_error(dir, "service not enabled"); >        } Nit picking. In this case the service is disabled entirely regardless dir and it uses the same message with the case where service is disabled per repo later on. Maybe we could reword it a little bit to differentiate the two cases? Say the first case "service disabled", and the second one "service not enabled"? -- Duy