From: Duy Nguyen Date: Fri, 10 Jun 2016 12:14:18 GMT Subject: Re: [PATCH 24/26] upload-pack: split check_unreachable() in two, prep for get_reachable_list() Message-ID: In-Reply-To: On Mon, Jun 6, 2016 at 2:43 AM, Eric Sunshine wrote: >> /* >> * The commits out of the rev-list are not ancestors of >> * our ref. >> */ >> - i = read_in_full(cmd.out, namebuf, 1); >> + i = read_in_full(cmd.out, buf, 1); > > s/1/sizeof(buf)/ perhaps or does that make the intent less clear? Yeah I think so. "1" makes it obvious that we do not care about the actual content (or at least raise some eyebrows and force the reader to understand this entire function). sizeof(buf), not so much. -- Duy