From: Duy Nguyen Date: Sat, 07 Apr 2018 09:52:34 GMT Subject: Re: [PATCH 4/3] Makefile: untangle DEVELOPER and -Werror Message-ID: In-Reply-To: <20180406214236.GF7870@sigill.intra.peff.net> On Fri, Apr 6, 2018 at 11:42 PM, Jeff King wrote: > On Tue, Apr 03, 2018 at 05:17:00PM +0200, Duy Nguyen wrote: > >> It's not that complex. With the EAGER_DEVELOPER patch removed, we can >> have something like this where eager devs just need to put >> >> DEVOPTS = gentle no-suppression >> >> and you put >> >> DEVOPTS = gentle >> >> (bad naming, I didn't spend time thinking about names) > > It seems to me like we're losing the point of DEVELOPER here. I thought > the idea was to have a turn-key flag you could set to get extra linting > on your commits. But now we're tweaking all kinds of individual options. > At some point are we better off just letting you put "-Wno-foo" in your > CFLAGS yourself? It's because what AEvar wanted is no longer a dev thing :) > I don't mind the version-based checks because they're automatic, so the > feature remains turn-key. But this kind of DEVOPTS seems like a step in > the wrong direction. > > -Peff -- Duy