From: Nguyen Thai Ngoc Duy Date: Tue, 04 Sep 2012 12:40:33 GMT Subject: Re: [PATCH 5/9] Refactor excluded and path_excluded Message-ID: In-Reply-To: <1346544731-938-6-git-send-email-git@adamspiers.org> On Sun, Sep 2, 2012 at 7:12 AM, Adam Spiers wrote: > extern void path_exclude_check_init(struct path_exclude_check *, struct dir_struct *); > extern void path_exclude_check_clear(struct path_exclude_check *); > +extern struct exclude *path_excluded_1(struct path_exclude_check *, const char *, > + int namelen, int *dtype); > extern int path_excluded(struct path_exclude_check *, const char *, int namelen, int *dtype); Exported functions should have nicer names than *_1. No idea what are better names though, maybe exclude_path? -- Duy