From: Jacob Keller Date: Thu, 18 Aug 2016 20:44:09 GMT Subject: Re: [PATCH v7 6/7] submodule: refactor show_submodule_summary with helper function Message-ID: In-Reply-To: On Thu, Aug 18, 2016 at 1:39 PM, Stefan Beller wrote: > On Thu, Aug 18, 2016 at 1:24 PM, Jacob Keller wrote: >> On Thu, Aug 18, 2016 at 12:04 PM, Stefan Beller wrote: >>> On Wed, Aug 17, 2016 at 5:51 PM, Jacob Keller wrote: >>>> + if (is_null_sha1(one)) >>>> + message = "(new submodule)"; >>>> + else if (is_null_sha1(two)) >>>> + message = "(submodule deleted)"; >>>> + >>>> + if (add_submodule_odb(path)) { >>>> + if (!message) >>>> + message = "(submodule not initialized)"; >>> >>> Before it was "(not initialized)" for this case, I think we'd rather keep that? >>> Though this code path is only used by the porcelain commands, we'd rather not >>> want to change this in a subtle way in this commit. >>> >>> If we were to change those, we could discuss if we want to go with >>> full sentences >>> all the time: >>> >>> submodule is new >>> submodule is deleted >>> submodule is not initialized >>> >>> >> >> I agree, I'll make a new patch that does this as a cleanup prior to >> this re-work. > > I was actually not suggesting to change that. I rather wanted to point out > that if we'd want that we'd rather do it consistently and in a different patch. > Sorry for not being clear. > > Thanks, > Stefan > Sorry for being unclear myself, too. I'm keeping it as "not initialized" and updating the description of the patch that changed it from "not checked out" to "not initialized" Thanks, Jake >> >> Thanks, >> Jake