From: Philip Oakley Date: Sun, 09 Jun 2013 22:44:11 GMT Subject: Re: [PATCH 2/3] test: improve rebase -q test Message-ID: In-Reply-To: From: "Felipe Contreras" Sent: Sunday, June 09, 2013 8:33 PM > On Sun, Jun 9, 2013 at 2:20 PM, Junio C Hamano > wrote: >> Felipe Contreras writes: >> >>> On Sun, Jun 9, 2013 at 1:30 PM, Junio C Hamano >>> wrote: >>> >>>> --- a/t/test-lib-functions.sh >>>> +++ b/t/test-lib-functions.sh >>>> @@ -606,6 +606,18 @@ test_cmp() { >>>> $GIT_TEST_CMP "$@" >>>> } >>>> >>>> +# Check if the file expected to be empty is indeed empty, and >>>> barfs >>>> +# otherwise. >>>> + >>>> +test_output_must_be_empty () { >>> >>> Why such a big name? test_empty() does the trick. >> >> Primarily in order to avoid that exact name "test_empty" that others >> may want to use for a helper to check that the contents of a string >> variable is empty. > > Which is never going to happen. > While folks do use such simplistic names, given that the patch had many call sites, I do think Filipe's short name would quickly become the accepted test name and not cause any great difficulties. regards Philip