From: Robert Haines Date: Tue, 24 Jun 2008 14:08:16 GMT Subject: Re: git-clone works with ssh but not with http/https/git Message-ID: In-Reply-To: >> So your clone address for git:// is wrong, you don't need the /pub/ >> git: >> git clone git://erez.zilber@kites/erez.zilber/my_test.git >> As you've moved the root of the filesystem as far as git-daemon is >> concerned >> to /pub/git with the --base-path option. > > I understand. However, when I try to run it according to your > suggestion: > > [root@kd001 t]# git clone git://erez.zilber@kites/erez.zilber/ > my_test.git > Initialized empty Git repository in /home/erez.zilber/work/tmp/t/ > my_test/.git/ > fatal: Unable to look up erez.zilber@kites (port 9418) (Name or > service not known) > fetch-pack from 'git://erez.zilber@kites/erez.zilber/my_test.git' > failed. That error is saying that the name of the service is wrong, so you're right to do it without the "erez.zilber@" bit. > I also tried to run it without "erez.zilber@": > > [root@kd001 t]# git clone git://kites/erez.zilber/my_test.git > Initialized empty Git repository in /home/erez.zilber/work/tmp/t/ > my_test/.git/ > kites[0: 172.16.1.11]: errno=Connection refused > fatal: unable to connect a socket (Connection refused) > fetch-pack from 'git://kites/erez.zilber/my_test.git' failed. This looks like that either there is nothing listening (if you're running though xinetd have you restarted it? And have you added the right bits to /etc/services?) or there's a firewall in the way... git defaults to 9418 so check that it's open. > Is there any log file on the server that can help me trace this > problem (something like /var/log/httpd/error_log but for the git > protocol)? on my machine (running via xinetd) it goes straight into /var/log/ messages. A grep -i git on that file should produce something. Cheers, Rob