From: Bert Wesarg Date: Mon, 02 May 2011 14:25:11 GMT Subject: Re: [PATCH/RFC 1/4] grep: prepare for re-using the space of the regexp member in struct grep_pat Message-ID: In-Reply-To: On Mon, May 2, 2011 at 15:27, Thiago Farina wrote: > On Mon, May 2, 2011 at 8:39 AM, Bert Wesarg wrote: >> diff --git a/grep.h b/grep.h >> index 06621fe..9912c11 100644 >> --- a/grep.h >> +++ b/grep.h >> @@ -32,7 +32,9 @@ struct grep_pat { >>        const char *pattern; >>        size_t patternlen; >>        enum grep_header_field field; >> -       regex_t regexp; >> +       union { >> +               regex_t regexp; >> +       } u; > > Instead of u, would be worth to rename it to something more descriptive? I followed struct grep_expr, where u is also used. But I'm open for a better name, if you have one. Bert