From: Erik Faye-Lund Date: Thu, 19 May 2011 19:19:14 GMT Subject: Re: [PATCH] compat: add a getpass() compatibility function Message-ID: In-Reply-To: <8B762D96-54CF-4E42-BF90-7790E900AA30@gieschke.de> On Thu, May 19, 2011 at 9:16 PM, Rafael Gieschke wrote: > > Am 19.05.2011 um 20:07 schrieb Erik Faye-Lund: >> diff --git a/compat/mingw.h b/compat/mingw.h >> index 62eccd3..e37d557 100644 >> --- a/compat/mingw.h >> +++ b/compat/mingw.h >> @@ -48,6 +48,8 @@ typedef int socklen_t; >> #define EAFNOSUPPORT WSAEAFNOSUPPORT >> #define ECONNABORTED WSAECONNABORTED >> >> +#define PASS_MAX 512 >> + > > It might be worth to have this in git-compat-util.h, so it can also be used by compat/getpass.c. I'm not sure about the name, however; it's a remote password and MAX_PASS is about local passwords AFAIK. Maybe PASS_MAX_REMOTE or something similiar. Like that, compat/getpass.c could also be used in case MAX_PASS has some insanely low value on a platform. > > PASS_MAX should be defined in limits.h (which is included by git-compat-util.h) on POSIX platforms: http://pubs.opengroup.org/onlinepubs/007908799/xsh/limits.h.html If it turns out it's not on some platforms, perhaps a define-guarded version would make sense in git-compat-util.h instead.