From: Nguyen Thai Ngoc Duy Date: Tue, 10 May 2011 12:59:29 GMT Subject: Re: [PATCH 0/4] convert.c clean-up Message-ID: In-Reply-To: <1304978701-19310-1-git-send-email-gitster@pobox.com> On Tue, May 10, 2011 at 5:04 AM, Junio C Hamano wrote: > Yeah, I think that would probably make more sense. If a file is small > enough, it is more sensible to send it to a loose object just like any > other files. We do not want to invite users to make a mistake of marking > it as bigdata and send it straight to a packfile. Having one less knob to > tweak is always a good thing to do. > > However, while reviewing your patch, I noticed that convert.c was littered > with misnamed types, variables and functions to the point to make it > almost unreadble as the result of its evolution.  I originally wrote this > series so that I can add "bigdata" sensibly, and it turns out that there > is no benefit to do so for now, but the clean-up by itself would be worth > it. I still don't like "bigdata" attribute. It sounds overlapping with bigFileThreshold we already have. Maybe "inPack", "packed" or "noLoose" a better name? It makes it quite clear that this attribute sends objects to a pack. If they want to process tiny files this way by setting inPack/noLoose, I don't care. But files larger than core.bigFileThreshold should be automatically marked "inPack/noLoose". > So there... Yeah, I wish you did this before I touched convert.c. Anyway it looks better from now on. -- Duy