From: Elijah Newren Date: Mon, 02 Aug 2010 04:25:00 GMT Subject: Re: [PATCH 06/16] upload-pack: use a separate variable to control whether internal rev-list is used Message-ID: In-Reply-To: <1280593105-22015-7-git-send-email-pclouds@gmail.com> Hi, 2010/7/31 Nguyễn Thái Ngọc Duy : > > Signed-off-by: Nguyễn Thái Ngọc Duy > --- >  upload-pack.c |    9 +++++---- >  1 files changed, 5 insertions(+), 4 deletions(-) > > diff --git a/upload-pack.c b/upload-pack.c > index dc464d7..e432e83 100644 > --- a/upload-pack.c > +++ b/upload-pack.c > @@ -160,8 +160,9 @@ static void create_pack_file(void) >        ssize_t sz; >        const char *argv[10]; >        int arg = 0; > +       int internal_rev_list = shallow_nr; I've got the exact same changes in one of my in-progress-patches in my sparse-clone branch. That is, other than the variable name, but I like yours better. Needless to say, I agree with this change. :-)