From: Ævar Arnfjörð Bjarmason Date: Sun, 25 Jul 2010 08:38:03 GMT Subject: Re: [PATCH 6/9] t7508 (status): modernize style Message-ID: In-Reply-To: <20100725005942.GF18420@burratino> On Sun, Jul 25, 2010 at 00:59, Jonathan Nieder wrote: > Some cleanups to make this test script easier to read and use, > such as: > >  - put setup code in test_expect_success scripts to make the >   test script easier to scan through; > >  - avoid a pipe to test_decode_color that forgets the exit status of >   "git status", by redirecting to a temporary file (named "actual") >   for that function to consume instead; > >  - remove precomputed object IDs; > >  - reset configuration after each test, so there is less state >   for a reader to keep in mind. These changes are all good. Well spotted with the test_might_fail() additions, adding forgotten &&, and turning the >expect code setup into their own tests. Acked.