From: Elijah Newren Date: Sat, 11 Sep 2010 17:19:09 GMT Subject: Re: [PATCH 0/8] en/object-list-with-pathspec v4 Message-ID: In-Reply-To: <1283961023-4491-1-git-send-email-pclouds@gmail.com> Hi, 2010/9/8 Nguyễn Thái Ngọc Duy : > OK it's good enough now. I no longer use struct exclude_list. > Its name does not really match the semantics. > > The last two patches implement tree exclusion and are not meant > for submission to en/object-list-with-pathspec. I wanted to see > if the new struct was extensible. And I need tree exclusion anyway > in my narrow clone. Perhaps the last two patches should be split off and submitted separately? I really like your work here to add negated pathspecs; they'll be really helpful for me. However, as you say, they are really moving into a different topic. I've reviewed and tested patches 1-4 of this series, and they look good to me. (Am I supposed to add a Reviewed-by and Tested-by or an Acked-by for these? Still not sure what the rules are there). Patches 5-6 are already part of pu (modulo the return of tree_entry(), which is nice) and already have my signoff, so I don't need to comment on those further. I've got some comments for patches 7 & 8, which I think may need a little more work; I'll add them to the individual emails. Elijah