From: Ævar Arnfjörð Bjarmason Date: Thu, 19 Aug 2010 12:53:16 GMT Subject: Re: What's cooking in git.git (Aug 2010, #04; Wed, 18) Message-ID: In-Reply-To: <7vfwyb8skr.fsf@alter.siamese.dyndns.org> On Wed, Aug 18, 2010 at 22:27, Junio C Hamano wrote: > [New Topics] > > * ab/maint-reset-mixed-w-pathspec-advice (2010-08-15) 1 commit >  - reset: Better warning message on git reset --mixed > > Probably needs a "better" title; the commit shouldn't advertise itself > being "better" (or "clean" for that matter), but say what it changed and > leave it to the readers to judge if it is better. s/Better/Clarify/ is as good as I can make it without making the subject line too long. > * ab/test-1 (2010-08-18) 5 commits >  . t/t0000-basic.sh: Run the passing TODO test inside its own test-lib >  . test-lib: Allow overriding of TEST_DIRECTORY >  . test-lib: Use "$GIT_BUILD_DIR" instead of "$TEST_DIRECTORY"/../ >  . test-lib: Use $TEST_DIRECTORY or $GIT_BUILD_DIR instead of $(pwd) and ../ >  . Merge branch 'ab/i18n' into ab/test-1 >  (this branch uses ab/i18n and ab/test.) > > Not merged to 'pu' as it seemed to have broken something. What does it seem to have broken? I can't fix it if I don't know what's wrong. It Works For Me. > * ab/perl-install (2010-08-03) 1 commit >  (merged to 'next' on 2010-08-14 at f2a27ee) >  + perl/Makefile: Unset INSTALL_BASE when making perl.mak > > * ab/test (2010-08-16) 43 commits >  (merged to 'next' on 2010-08-18 at f88bdb1) >  + cvs tests: do not touch test CVS repositories shipped with source >  + t/t9602-cvsimport-branches-tags.sh: Add a PERL prerequisite >  + t/t9601-cvsimport-vendor-branch.sh: Add a PERL prerequisite >  + t/t7105-reset-patch.sh: Add a PERL prerequisite >  + t/t9001-send-email.sh: convert setup code to tests >  + t/t9001-send-email.sh: change from skip_all=* to prereq skip >  + t/t9001-send-email.sh: Remove needless PROG=* assignment >  + t/t9600-cvsimport.sh: change from skip_all=* to prereq skip >  + lib-patch-mode tests: change from skip_all=* to prereq skip >  + t/t3701-add-interactive.sh: change from skip_all=* to prereq skip >  + tests: Move FILEMODE prerequisite to lib-prereq-FILEMODE.sh >  + t/Makefile: Create test-results dir for smoke target >  + git-notes: Run partial expensive test everywhere >  + t/t3300-funny-names: change from skip_all=* to prereq skip >  + t/t3902-quoted: change from skip_all=* to prereq skip >  + t/t4016-diff-quote: change from skip_all=* to prereq skip >  + t/t5503-tagfollow: change from skip_all=* to prereq skip >  + t/t7005-editor: change from skip_all=* to prereq skip >  + t/t5705-clone-2gb: change from skip_all=* to prereq skip >  + t/t1304-default-acl: change from skip_all=* to prereq skip >  + t/README: Update "Skipping tests" to align with best practices >  + t/t7800-difftool.sh: Skip with prereq on no PERL >  + t/t5800-remote-helpers.sh: Skip with prereq on python <2.4 >  + t/t4004-diff-rename-symlink.sh: use three-arg >  + tests: implicitly skip SYMLINKS tests using >  + Makefile: make gcov invocation configurable >  + t/README: Add a note about the dangers of coverage chasing >  + t/README: A new section about test coverage >  + Makefile: Add cover_db_html target >  + Makefile: Add cover_db target >  + Makefile: Split out the untested functions target >  + Makefile: Include subdirectories in "make cover" reports >  + gitignore: Ignore files generated by "make coverage" >  + t/README: Add SMOKE_{COMMENT,TAGS}= to smoke_report target >  + t/Makefile: Can't include GIT-BUILD-OPTIONS, it's a .sh >  + t/README: Document the Smoke testing >  + tests: Infrastructure for Git smoke testing >  + test-lib: Multi-prereq support only checked the last prereq >  + tests: A SANITY test prereq for testing if we're root >  + t/README: Document the predefined test prerequisites >  + test-lib: Print missing prerequisites in test output >  + test-lib: Add support for multiple test prerequisites >  + test-lib: Don't write test-results when HARNESS_ACTIVE >  (this branch is used by ab/test-1.) > > Previously many individual topic branches from the same author, all > regarding tests.  I thought it probably was ready for 'next' but was > holding off as we seem to still keep getting many fixes on top. Thanks for merging these. > * ab/i18n (2010-07-25) 4 commits >  - tests: locate i18n lib&data correctly under --valgrind >  - gettext: setlocale(LC_CTYPE, "") breaks Git's C function assumptions >  - tests: rename test to work around GNU gettext bug >  - Add infrastructure for translating Git with gettext >  (this branch is used by ab/test-1.) mmm, i18n brewing :)