From: Jay Soffian Date: Wed, 16 Feb 2011 21:33:15 GMT Subject: Re: [PATCH 2/2] Teach commit about CHERRY_PICK_HEAD Message-ID: In-Reply-To: <7vpqqrit8r.fsf@alter.siamese.dyndns.org> On Wed, Feb 16, 2011 at 4:07 PM, Junio C Hamano wrote: > Jay Soffian writes: > >> If the user wishes to reset authorship, that must now be done explicitly >> via --reset-author. > > This is not a new requirement, is it?  Even "commit -c $that_commit" > before the previous "commit -c CHERRY_PICK_HEAD" does use the original, > no? It is a new requirement for when the user does a bare "commit" _and_ CHERRY_PICK_HEAD exists. Normally a bare "commit" creates new authorship, but when CHERRY_PICK_HEAD exists, authorship is taken from CHERRY_PICK_HEAD commit unless --reset-author is specified. > I think the changed code is _MUCH_ easier to follow compared to the > previous round; the only thing the reader needs to keep in mind is that > the most of the change essentially is "s/in_merge/whence != FROM_COMMIT/" > and making that work. I think I was trying to be too clever in the previous round. >> * We remove a unused import from revert.c > > Micronit: s/import/include/. Okay. > So I think the above is the right thing to do, but we probably need a bit > of in-code comment to describe why we say "whence != FROM_MERGE" here. Will do. It took me several tries to understand what that code block was trying to do, so a comment will certainly help future readers. Thanks, j.