From: Ævar Arnfjörð Bjarmason Date: Fri, 25 Feb 2011 19:58:50 GMT Subject: Re: [PATCH v4 17/73] gettextize: git-branch "Deleted branch [...]" message Message-ID: In-Reply-To: <20110225075429.GF23037@elie> On Fri, Feb 25, 2011 at 08:54, Jonathan Nieder wrote: > Ævar Arnfjörð Bjarmason wrote: > >> --- a/builtin/branch.c >> +++ b/builtin/branch.c >> @@ -214,7 +214,7 @@ static int delete_branches(int argc, const char **argv, int force, int kinds) >>                       ret = 1; >>               } else { >>                       struct strbuf buf = STRBUF_INIT; >> -                     printf("Deleted %sbranch %s (was %s).\n", remote, >> +                     printf(_("Deleted %sbranch %s (was %s).\n"), remote, > > This patch might be might easier to read squashed with the previous > one (both for the sake of providing context to reviewers and avoiding > mixed-language output :)). I split it up from the rest because I always tried to group translations with the tests they broke, and only the tests they broke and vice versa. It was often a lot of work figuring out what translation broke what tests. IIRC splitting this all took me around half a day at the time. So while it's easy to find out what message is the relevant one in this case, this is an attribute of the series I'd really like to keep for future bookkeeping. It's nice to be able to annotate a line in the test suite and see a patch that changes *just* that message and related tests, not a lot of other unrelated messages.