From: Elijah Newren Date: Wed, 28 Jul 2010 16:47:19 GMT Subject: Re: [PATCH] upload-pack: remove unused "create_full_pack" code in do_rev_list Message-ID: In-Reply-To: <1280309950-5597-1-git-send-email-pclouds@gmail.com> Hi, 2010/7/28 Nguyễn Thái Ngọc Duy : > A bit of history in chronological order, the newest at bottom: > > - 80ccaa7 (upload-pack: Move the revision walker into a separate function.) >   do_rev_list was introduced with create_full_pack argument > > - 21edd3f (upload-pack: Run rev-list in an asynchronous function.) >   do_rev_list was now called by start_async, create_full_pack was >   passed by rev_list.data > > - f0cea83 (Shift object enumeration out of upload-pack) >   rev_list.data was now zero permanently. Creating full pack was >   done by passing --all to pack-objects > > - ae6a560 (run-command: support custom fd-set in async) >   rev_list.data = 0 was found out redudant and got rid of. > > Get rid of the code as well, for less headache while reading do_rev_list. Definitely a more detailed explanation than I gave for this patch (http://thread.gmane.org/gmane.comp.version-control.git/151667). :-)