From: Ævar Arnfjörð Bjarmason Date: Mon, 13 Sep 2010 12:11:32 GMT Subject: Re: [PATCH] t7003: Use test_commit instead of custom function Message-ID: In-Reply-To: <214E9A5B-E9CE-4B98-88EC-744DBE1F3C32@gernhardtsoftware.com> On Mon, Sep 13, 2010 at 04:14, Brian Gernhardt wrote: > > On Sep 10, 2010, at 6:06 PM, Brian Gernhardt wrote: > >> Not only is this unneeded code duplication, it also was something >> simply waiting to fail on case-insensitive file systems.  So replace >> all uses of make_commit with test_commit. > > To be more specific: this causes a failure in next on case-insensitive HFS+.  The commit that finally triggered the problem is 7ec344d: "filter-branch: retire --remap-to-ancestor", by using `git reset --hard A` which got confused on if 'A' was 'refs/branches/A' or './a' > > However, the patch applies to master or maint. And you've modified the casing so it passes? Maybe it should skip on case-insensitive systems instead, or perhaps we should modify it and test for that elsewhere.