From: Remi Galan Alfonso Date: Tue, 02 Jun 2015 09:23:48 GMT Subject: Re: [PATCH/RFCv2 2/2] git rebase -i: warn about removed commits Message-ID: <991806665.10972.1433237028896.JavaMail.zimbra@ensimag.grenoble-inp.fr> In-Reply-To: Matthieu Moy writes: > Galan Rémi writes: > > > Check if commits were removed (i.e. a line was deleted) and print > > warnings or abort git rebase according to the value of the > > configuration variable rebase.checkLevel. > > checkLevel does not seem to be a good name, because it doesn't say > _what_ is checked. I don't have really good proposal in mind, but maybe > > rebase.todoListCheckLevel > rebase.missinLinesCheckLevel > > ? I agree that we could use a better name. I'm thinking about > rebase.missingLinesCheckLevel or rebase.missingCommitsCheckLevel but I am worried that these names are too long. Maybe rebase.dropCheckLevel I don't really have better propositions right now. Rémi