From: Felipe Contreras Date: Wed, 10 Jun 2009 22:31:57 GMT Subject: Re: EasyGit Integration Message-ID: <94a0d4530906101531ja6f1deeob703f546d62e7599@mail.gmail.com> In-Reply-To: On Wed, Jun 10, 2009 at 7:03 AM, Linus Torvalds wrote: > > > On Tue, 9 Jun 2009, Theodore Tso wrote: >> >> My personal opinion is this kind of overloading is actually more >> confusing than simply adding a new name, such as "git revert-file". > > I'd agree, except I think it actually worked pretty well in "git > checkout". > > The alternative was to add yet another command for that, or to teach > people about the internal commands we did have. Adding the capability for > checkout to check out individual files - in addition to commits and > branches - I think worked pretty well. Why? What makes 'git checkout ' and 'git checkout -- ' similar at all? I would expect 'git checkout ' to be the same as 'git checkout -- .' In my mind these are 2 completely different commands. -- Felipe Contreras