From: Michael Haggerty Date: Thu, 14 Jan 2010 05:54:52 GMT Subject: [PATCH 13/18] rebase -i: Handle the author script all in one place in do_next Message-ID: <946239c2ed9c6bf1b536d96c6bf06788878c63b9.1263447038.git.mhagger@alum.mit.edu> In-Reply-To: This change has no practical effect but makes the code easier to follow. Signed-off-by: Michael Haggerty --- git-rebase--interactive.sh | 4 ++-- 1 files changed, 2 insertions(+), 2 deletions(-) diff --git a/git-rebase--interactive.sh b/git-rebase--interactive.sh index 04a1c3a..15b8605 100755 --- a/git-rebase--interactive.sh +++ b/git-rebase--interactive.sh @@ -449,6 +449,8 @@ do_next () { make_squash_message $squash_style $sha1 > "$MSG" failed=f author_script=$(get_author_ident_from_commit HEAD) + echo "$author_script" > "$AUTHOR_SCRIPT" + eval "$author_script" output git reset --soft HEAD^ pick_one -n $sha1 || failed=t case "$(peek_next_command)" in @@ -467,11 +469,9 @@ do_next () { rm -f "$GIT_DIR"/MERGE_MSG || exit ;; esac - echo "$author_script" > "$AUTHOR_SCRIPT" if test $failed = f then # This is like --amend, but with a different message - eval "$author_script" GIT_AUTHOR_NAME="$GIT_AUTHOR_NAME" \ GIT_AUTHOR_EMAIL="$GIT_AUTHOR_EMAIL" \ GIT_AUTHOR_DATE="$GIT_AUTHOR_DATE" \ -- 1.6.6