From: Kristoffer Haugsbakk Date: Tue, 03 Jun 2025 13:45:35 GMT Subject: Re: [PATCH v3 10/12] usage: allow dying without writing an error message Message-ID: <8dca137e-04a5-4609-89ca-c89c31ce2b2d@app.fastmail.com> In-Reply-To: On Tue, Jun 3, 2025, at 12:46, Patrick Steinhardt wrote: >> Ah, that makes so much difference. > > That reads better, but I guess we can improve it even further. How about > this instead: > > To retain the same error code as `die()` we have to use `exit(128)`, > which is easy to get wrong and leaves magical numbers all over our > codebase. Looks great. Just s/magical numbers/magic numbers/