From: Alex Blewitt Date: Tue, 11 Aug 2009 12:53:38 GMT Subject: Re: [EGIT PATCH] Provide a more JavaBeans-style 'getName' accessor for the id Signed-off-by: Alex Blewitt Message-ID: <8ACC6C83-75FD-477C-9083-96CA426FC069@gmail.com> In-Reply-To: <20090810205907.GY1033@spearce.org> On 10 Aug 2009, at 21:59, "Shawn O." wrote: > Alex Blewitt wrote: >> That patch was originally mailed on the 11th May. Has it taken >> until now >> to notice the problem, or was the other method added in the last >> month or >> so? If I'm to blame, I apologise but didn't note any compile time >> issues >> at the time. > > Arrgh, you are right, I lost this patch in my inbox, and in the > interm we applied new features to RevTag which added getName there. . > >>> ./org/spearce/jgit/revwalk/RevTag.java:206: getName() in >>> org.spearce.jgit.revwalk.RevTag cannot override getName() in >>> org.spearce.jgit.lib.AnyObjectId; overridden method is final > > I can't apply this patch because getName() on RevTag is already > defined with a different meaning. :-( That sounds dangerous. We now have a .name() and a .getName() with different semantics. Can we not change the RevTag method name to something else so that we dont have an inconsistency? > Alex