From: David Kågedal Date: Mon, 06 Apr 2009 13:42:44 GMT Subject: Re: [RFC/PATCH 0/2] New 'stage' command Message-ID: <87vdphj3u3.fsf@krank.kagedal.org> In-Reply-To: <871vs5kjfw.fsf@krank.kagedal.org> David Kågedal writes: > We wouldn't have to use the "STAGE" or "WORKTREE" names, of course. It > doesn't have to look like refspecs even. The last example already has > a syntax that matches the suggestion: > > git diff --cached > > So, extrapolating this to "git diff --worktree --cached" would mean > what "git diff -R" means today etc. BTW, I don't really care much about whether it's spelled "cached" "index" "staged" or "dumbledore". I just want some regularity in the diff command. I'll happily let someone else figure out the taxonomy. -- David Kågedal