From: Junio C Hamano Date: Fri, 26 Jan 2007 23:46:00 GMT Subject: Re: [PATCH] Hash name is SHA-1 Message-ID: <7vzm85tkqv.fsf@assigned-by-dhcp.cox.net> In-Reply-To: <200701261154.20723.andyparkins@gmail.com> Andy Parkins writes: > As a further to the above cleanups, I'm also planning to fix all the sha1 > named variables to be "hash" or "object" or something. It strikes me that > this plan is related to this cleanup and might fix some of the issues like: > >> + "git-read-tree ( | " >> + "[[-m [--aggressive] | --reset | --prefix=] " >> + "[-u | -i]] [--exclude-per-directory=] " >> + " [ []])"; I've thought about this more than once but I do not think it is worth to rename variable and functions wholesale. When we do fix-ups to a particular function that has "unsigned char sha1[20]" renaming the variable to hash[OBNAME_SIZE] at the same time would be of less impact, although the clean-up may take longer. On the other hand, I think the usage strings are fair game.