From: Junio C Hamano Date: Sun, 10 Jun 2007 22:19:00 GMT Subject: Re: [PATCH] Port git-tag.sh to C. Message-ID: <7vzm375u7f.fsf@assigned-by-dhcp.cox.net> In-Reply-To: <20070610221306.GF27340@coredump.intra.peff.net> Jeff King writes: > This is the same git-send-email bug that we fixed recently (missing > MIME-Version header). Just look for the vger "we munged your message" > headers in the version you received. Ahh. You are right. The message does have these: X-Warning: Original message contained 8-bit characters, however during the SMTP transport session the receiving system did not announce capability of receiving 8-bit SMTP (RFC 1651-1653), and as this message does not have MIME headers (RFC 2045-2049) to enable encoding change, we had very little choice. X-Warning: We ASSUME it is less harmful to add the MIME headers, and convert the text to Quoted-Printable, than not to do so, and to strip the message to 7-bits.. (RFC 1428 Appendix A) X-Warning: We don't know what character set the user used, thus we had to write these MIME-headers with our local system default value.