From: Junio C Hamano Date: Mon, 12 Aug 2013 17:15:48 GMT Subject: Re: [PATCH] diff: remove ternary operator evaluating always to true Message-ID: <7vzjsmzv7f.fsf@alter.siamese.dyndns.org> In-Reply-To: <52089D81.5010506@googlemail.com> Stefan Beller writes: > On 08/12/2013 07:46 AM, Junio C Hamano wrote: >> I think that is an overall improvement, especially if we also update >> the checks of {one,two}->mode made for the block that deals with >> submodules to use DIFF_FILE_VALID(). >> >> Thanks. >> > > So, do I understand your reasoning, when proposing this patch? I meant the condition in the "if" statement, not the parameters to show_submodule_summary(). There are checks on ->mode fields that bypass the DIFF_FILE_VALID() macro, hurting readability.