From: Junio C Hamano Date: Mon, 12 Jul 2010 16:45:51 GMT Subject: Re: [PATCH v3 02/13] parse-options: add two helper functions Message-ID: <7vy6dgbqdc.fsf@alter.siamese.dyndns.org> In-Reply-To: <1278829141-11900-2-git-send-email-struggleyb.nku@gmail.com> Bo Yang writes: > +int parse_options_next(struct parse_opt_ctx_t *ctx, int retain) I think the latter is usually called "keep". > +{ > + if (ctx->argc <= 0) > + return -1; > + > + if (retain == 1) Should this really check for "1", or would if (keep) be more conventional?