From: Junio C Hamano Date: Mon, 12 Nov 2007 19:51:44 GMT Subject: Re: [PATCH 4/6] add ref_abbrev_matches_full_with_rules() Message-ID: <7vve872qen.fsf@gitster.siamese.dyndns.org> In-Reply-To: <11947897083265-git-send-email-prohaska@zib.de> Steffen Prohaska writes: > +int ref_abbrev_matches_full_with_rules(const char *abbrev_name, const char *full_name, const char **rules) > +{ > + const char **p; > + const int abbrev_name_len = strlen(abbrev_name); > + > + for (p = rules; *p; p++) { > + if (!strcmp(full_name, mkpath(*p, abbrev_name_len, abbrev_name))) { > + return 1; > + } > + } > + > + return 0; > +} > + How about calling this simply "ref_abbrev_matches()" or "refname_match()" which is even shorter?