From: Junio C Hamano Date: Wed, 16 Jan 2013 19:19:46 GMT Subject: Re: [PATCH] git-remote: distinguish between default and configured URLs Message-ID: <7vvcaxvstp.fsf@alter.siamese.dyndns.org> In-Reply-To: <50F6A0F0.70800@drmicha.warpmail.net> Michael J Gruber writes: > In short, the separate listing is correct, but in this case there's no > improvement in readability. Yes, I think the "insteadOf" rewrite is a related but a separate issue. Is "remote -v" meant for diagnosing remote.origin.{url,pushurl} that are misconfigured? If not, the output just should just say the final outcome, i.e. what destinations we will fetch from and push to, without cluttering the output. If on the other hand it is to help users debug their configuration, the output also needs to explain exactly what made us decide those destinations to use (e.g. to discover there was a leftover insteadof in $HOME/.gitconfig the user forgot about).