From: Junio C Hamano Date: Tue, 07 Sep 2010 04:52:01 GMT Subject: Re: [PATCH 6/7] t1303 (config): style tweaks Message-ID: <7vtym2p34e.fsf@alter.siamese.dyndns.org> In-Reply-To: <20100907043050.GA13291@sigill.intra.peff.net> Jeff King writes: > ... But I really don't want to be too draconian > about "everything must go into test_expect_success". Sure, if you are > executing commands that might have output, or might be of interest to > the user, put them there. But I find this a lot more readable: > > cat >expect <<'EOF' > ... some expected output ... > EOF > test_expect_success 'frob it' ' > git frob && > test_cmp expect actual > ' > > than: > > test_expect_success 'frob it' ' > cat >expect <<"EOF" && > ... some expected output ... > EOF > git frob && > test_cmp expect actual > ' I agree. My gut feeling has been that any set-up that uses "git" should never be outside test_expect_success, but things like cat <