From: Junio C Hamano Date: Sun, 12 Sep 2010 17:37:47 GMT Subject: Re: [PATCH/RFC 3/3] t/gitweb-lib.sh: Add support for GITWEB_TEST_INSTALLED Message-ID: <7vtylueuc4.fsf@alter.siamese.dyndns.org> In-Reply-To: <1284284466-14506-4-git-send-email-jnareb@gmail.com> Jakub Narebski writes: > It is an RFC because I am not sure where to put documentation, > i.e. description of GITWEB_TEST_INSTALLED. Should it be put in > t/README, in gitweb/README, or in gitweb/INSTALL, or in > t/gitweb-lib.sh header? I think the comment in this file is fine. > + # You can set the GITWEB_TEST_INSTALLED environment variable to > + # the gitwebdir (the directory where gitweb is installed / deployed to) > + # of an existing gitweb instalation to test that installation. > + if test -n "$GITWEB_TEST_INSTALLED" ; then > + SCRIPT_NAME="$GITWEB_TEST_INSTALLED/gitweb.cgi" > + test -f "$SCRIPT_NAME" || > + error "Cannot find gitweb.cgi at $GITWEB_TEST_INSTALLED." I don't know if GIT_WEB_TEST_INSTALLED=/path/to/some/directory (naming the directory that houses the script which must be named gitweb.cgi) is easier to use than GIT_WEB_TEST_INSTALLED=/path/to/some/gitweb.perl (naming the script that is allowed to be renamed).