From: Junio C Hamano Date: Wed, 25 Mar 2009 23:34:53 GMT Subject: Re: [PATCH] git-filter-branch: avoid collisions with variables in eval'ed commands Message-ID: <7vskl1w50i.fsf@gitster.siamese.dyndns.org> In-Reply-To: <20090325215848.GV8940@machine.or.cz> Petr Baudis writes: > On Wed, Mar 25, 2009 at 03:33:31PM -0600, Elijah Newren wrote: >> Hi, >> >> On Wed, Mar 25, 2009 at 3:24 PM, Petr Baudis wrote: >> > On Wed, Mar 25, 2009 at 03:13:01PM -0600, newren@gmail.com wrote: >> >> From: Elijah Newren >> >> >> >> Avoid using simple variable names like 'i', since user commands are eval'ed >> >> and may clash with and overwrite our values. >> >> >> >> Signed-off-by: Elijah Newren >> > >> > Almost-acked-by: Petr Baudis >> > >> > But: >> > >> >>-i=0 >> >>+git_filter_branch_count=0 >> > >> > Why branch_count? It counts commits, not branches, doesn't it? >> >> Oh, I was just changing i->git_filter_branch_i, then thought as long >> as it was long I might as well use a word instead of "i". Didn't >> think about the combined meaning. How about >> "git_filter_branch_commit_count"? Maybe a double underscore between >> the "namespace" and the "variable"? > > Oh, I sort of thought it's "git-filter branch count", not > "git-filter-branch count". I'm dumbed down from all day spent in IKEA > I guess. :/ > > I'd personally just use $__git_i, $__git_commit or something, but YMMV. Heh, I'll drop lmost-a from your earlier message and commit the result. Thanks.