From: Junio C Hamano Date: Tue, 22 May 2012 18:00:18 GMT Subject: Re: [PATCH 1/2] completion: rename _git and _gitk Message-ID: <7vsjes3xl9.fsf@alter.siamese.dyndns.org> In-Reply-To: <20120522082406.GA6001@goldbirke> SZEDER Gábor writes: >> -_git () >> +_main_git () > >> -_gitk () >> +_main_gitk () > > After all those namespace discussions the names of these functions > should start with _git or __git. As these are pure implementation internal details that are called from very limited places, I do not think Felipe minds a patch to update them. Personally I would find _git_git or __git_git even more mysterious and begs one-liner comments above their definition, though. Thanks.