From: Junio C Hamano Date: Thu, 15 Sep 2005 08:03:39 GMT Subject: Re: Tool renames. Message-ID: <7vr7bqahb8.fsf@assigned-by-dhcp.cox.net> In-Reply-To: <43290D0F.9060408@zytor.com> "H. Peter Anvin" writes: > I noticed you also renamed git-ssh-{push,pull}. These tools rely on > having the same names on both sides, so you have introduced a major > version skew problem. True. It seems that both myself and Daniel did not think that would be a major problem when we were discussing the tool renames. As a workaround, you could always say GIT_SSH_PULL='blah' and GIT_SSH_PUSH='bah' when you run either side to name what will be run on the other end. Now the interesting problem is if we should rename these environment variables ...