From: Junio C Hamano Date: Thu, 15 Sep 2005 08:52:19 GMT Subject: Re: Tool renames. Message-ID: <7vr7bq4ssc.fsf@assigned-by-dhcp.cox.net> In-Reply-To: <7vr7bqahb8.fsf@assigned-by-dhcp.cox.net> Junio C Hamano writes: > "H. Peter Anvin" writes: > >> I noticed you also renamed git-ssh-{push,pull}. These tools rely on >> having the same names on both sides, so you have introduced a major >> version skew problem. > > True. It seems that both myself and Daniel did not think that > would be a major problem when we were discussing the tool > renames. > > As a workaround, you could always say GIT_SSH_PULL='blah' and > GIT_SSH_PUSH='bah' when you run either side to name what will be > run on the other end. Come to think of it, I should be able to build git-ssh-push and git-ssh-pull as fully backward compatible way to call the counterpart with original name, instead of supplying just symlinks the same way I do currently. Let me work do that before I do 0.99.7 this weekend. > Now the interesting problem is if we should rename these > environment variables ... And the old and new binaries will be built separately anyway, I could use GIT_SSH_FETCH and GIT_SSH_UPLOAD in the newname binaries while keeping the old names in oldname binaries. Ack?