From: Junio C Hamano Date: Sun, 28 Oct 2007 07:28:36 GMT Subject: Re: [PATCH 6/8] add ref_cmp_full_short() comparing full ref name with a short name Message-ID: <7vr6jfwvdn.fsf@gitster.siamese.dyndns.org> In-Reply-To: <11935038084130-git-send-email-prohaska@zib.de> Steffen Prohaska writes: > diff --git a/sha1_name.c b/sha1_name.c > index b820909..2a1e093 100644 > --- a/sha1_name.c > +++ b/sha1_name.c > @@ -249,6 +249,20 @@ static const char *ref_fmt[] = { > NULL > }; > > +int ref_cmp_full_short(const char *full_name, const char *short_name) > +{ > + const char **p; > + const int short_name_len = strlen(short_name); > + > + for (p = ref_fmt; *p; p++) { > + if (strcmp(full_name, mkpath(*p, short_name_len, short_name)) == 0) { We usually say "!strcmp()" instead for readability.