From: Junio C Hamano Date: Wed, 18 Apr 2007 15:56:25 GMT Subject: Re: [PATCH 0/2] Custom low-level merge driver support. Message-ID: <7vps61isly.fsf@assigned-by-dhcp.cox.net> In-Reply-To: <20070418153445.GC12888@admingilde.org> Martin Waitz writes: > On Wed, Apr 18, 2007 at 12:48:48PM +0200, Johannes Schindelin wrote: >> On Wed, 18 Apr 2007, Junio C Hamano wrote: >> >> > [merge] >> > driver = ancient merge %A %O %B >> >> Why not do something like >> >> [merge.driver] >> ancient = merge %A %O %B > > or > > [merge "ancient"] > driver = merge %A %O %B Actually, I've considered the latter. Johannes's goes against the usual three-level configuration variable naming rules. If you have 'user definable' part in the name, that should be at the second level. Which yours does. The only reason I did not do it your way was because we would need to have three lines per driver (one [merge "foo"] section per driver, a "driver" line, and a blank line for readability after that), which at the time I wrote it felt a bit wasteful, and it was late. But I think I like yours much better. It probably is trivial to change the rule before it hits 'next'.