From: Junio C Hamano Date: Wed, 02 Jul 2008 04:41:58 GMT Subject: What's cooking in git.git (topics) Message-ID: <7vprpwhp7t.fsf@gitster.siamese.dyndns.org> In-Reply-To: <7v3amv1e8n.fsf@gitster.siamese.dyndns.org> Here are the topics that have been cooking. Commits prefixed with '-' are only in 'pu' while commits prefixed with '+' are in 'next'. The topics list the commits in reverse chronological order. The topics meant to be applied to the maintenance series have "maint-" in their names. It already is beginning to become clear what 1.6.0 will look like. What's already in 'next' all are well intentioned (I do not guarantee they are already bug-free --- that is what cooking them in 'next' is for) and are good set of feature enhancements. Bigger changes will be: * MinGW will be in. * With the default Makefile settings, most of the programs will be installed outside your $PATH, except for "git", "gitk", "git-gui" and some server side programs that need to be accessible for technical reasons. Invoking a git subcommand as "git-xyzzy" from the command line has been deprecated since early 2006 (and officially announced in 1.5.4 release notes); use of them from your scripts after adding output from "git --exec-path" to the $PATH will still be supported in 1.6.0, but users are again strongly encouraged to adjust their scripts to use "git xyzzy" form, as we will stop installing "git-xyzzy" hardlinks for built-in commands in later releases. * git-merge will be rewritten in C. * default pack and idx versions will be updated as scheduled for some time ago. * GIT_CONFIG, which was only documented as affecting "git config", but actually affected all git commands, now only affects "git config". GIT_LOCAL_CONFIG, also only documented as affecting "git config" and not different from GIT_CONFIG in a useful way, is removed. ---------------------------------------------------------------- [New Topics] * js/import-zip (Mon Jun 30 19:50:44 2008 +0100) 1 commit + Add another fast-import example, this time for .zip files * js/apply-root (Tue Jul 1 00:44:47 2008 +0100) 1 commit + Teach "git apply" to prepend a prefix with "--root=" * db/no-git-config (Mon Jun 30 03:37:47 2008 -0400) 1 commit + Only use GIT_CONFIG in "git config", not other programs ---------------------------------------------------------------- [Will merge to master soon] * j6t/mingw (Sat Nov 17 20:48:14 2007 +0100) 38 commits + compat/pread.c: Add a forward declaration to fix a warning + Windows: Fix ntohl() related warnings about printf formatting + Windows: TMP and TEMP environment variables specify a temporary directory. + Windows: Make 'git help -a' work. + Windows: Work around an oddity when a pipe with no reader is written to. + Windows: Make the pager work. + When installing, be prepared that template_dir may be relative. + Windows: Use a relative default template_dir and ETC_GITCONFIG + Windows: Compute the fallback for exec_path from the program invocation. + Turn builtin_exec_path into a function. + Windows: Use a customized struct stat that also has the st_blocks member. + Windows: Add a custom implementation for utime(). + Windows: Add a new lstat and fstat implementation based on Win32 API. + Windows: Implement a custom spawnve(). + Windows: Implement wrappers for gethostbyname(), socket(), and connect(). + Windows: Work around incompatible sort and find. + Windows: Implement asynchronous functions as threads. + Windows: Disambiguate DOS style paths from SSH URLs. + Windows: A rudimentary poll() emulation. + Windows: Implement start_command(). + Windows: A pipe() replacement whose ends are not inherited to children. + Windows: Wrap execve so that shell scripts can be invoked. + Windows: Implement setitimer() and sigaction(). + Windows: Fix PRIuMAX definition. + Windows: Implement gettimeofday(). + Make my_mktime() public and rename it to tm_to_time_t() + Windows: Work around misbehaved rename(). + Windows: always chmod(, 0666) before unlink(). + Windows: A minimal implemention of getpwuid(). + Windows: Implement a wrapper of the open() function. + Windows: Strip ".exe" from the program name. + Windows: Handle absolute paths in safe_create_leading_directories(). + Windows: Treat Windows style path names. + setup.c: Prepare for Windows directory separators. + Windows: Use the Windows style PATH separator ';'. + Add target architecture MinGW. + Compile some programs only conditionally. + Add compat/regex.[ch] and compat/fnmatch.[ch]. No explanation necessary ;-) ---------------------------------------------------------------- [Actively Cooking] * jc/reflog-expire (Sat Jun 28 22:24:49 2008 -0700) 2 commits - Make default expiration period of reflog used for stash infinite - Per-ref reflog expiry configuration As 1.6.0 will be a good time to make backward incompatible changes, the tip commit makes the default expiry period of stash 'never', unless you configure them to expire explicitly using gc.refs/stash.* variables. Needs consensus, but I am guessing that enough people would want stash that does not expire. We may want to change the commit topology used to represent a stash, as proposed in $gmane/85055 by Nana earlier. * jc/merge-theirs (Mon Jun 30 22:18:57 2008 -0700) 4 commits - Make "subtree" part more orthogonal to the rest of merge- recursive. + Teach git-merge to pass -X