From: Junio C Hamano Date: Mon, 26 Nov 2012 18:43:19 GMT Subject: Re: [PATCH 1/7] push: return reject reasons via a mask Message-ID: <7vobikryrc.fsf@alter.siamese.dyndns.org> In-Reply-To: <1353644515-17349-2-git-send-email-chris@rorvick.com> Chris Rorvick writes: > Pass all rejection reasons back from transport_push(). The logic is > simpler and more flexible with regard to providing useful feedback. > > Signed-off-by: Chris Rorvick > --- Thanks for a reroll. I do not think they are "masks", by the way. They are set of flags (i.e. a bitset). A bitset is often called "a mask" when it is used to "mask" a subset of bits in another bitset that has the real information, either to ignore irrelevant bits or to pick only the relevant bits from the latter. And your "reject_mask" is never used as a mask in this patch---it is the bitset that has the real information and it gets masked by constant masks like REJECT_NON_FF_HEAD. In any case, naming it as "reject_mask" is like calling a counter as "counter_int". It is more important to name it after its purpose than after its type, and because this is to record the reasons why the push was rejected, "rejection_reason" might be a better name for it.