From: Junio C Hamano Date: Wed, 30 Jan 2013 07:04:08 GMT Subject: Re: [PATCH v3 1/4] mergetool--lib: simplify command expressions Message-ID: <7vobg7m9sn.fsf@alter.siamese.dyndns.org> In-Reply-To: <1359526854-25132-1-git-send-email-davvid@gmail.com> David Aguilar writes: > Update variable assignments to always use $(command "$arg") > in their RHS instead of "$(command "$arg")" as the latter > is harder to read. Make get_merge_tool_cmd() simpler by > avoiding "echo" and $(command) substitutions completely. > > Signed-off-by: David Aguilar > --- > This is a replacement patch for what's currently in pu to > fix the empty "test -z" expression. Thanks. I think I already pushed out what I locally amended; will double check.