From: Junio C Hamano Date: Sat, 13 Dec 2008 22:37:13 GMT Subject: Re: [PATCH try 2] gitweb: Add option to put a trailing slash on pathinfo-style project URLs Message-ID: <7vmyez4s86.fsf@gitster.siamese.dyndns.org> In-Reply-To: Jakub Narebski writes: >> + # If you want a trailing slash on the project path (because, for >> + # example, you have a real directory at that URL and are using >> + # some rewrite magic to invoke gitweb), then set: >> + # $feature{'pathinfo'}{'default'} = [1, 1]; >> + > > Are any disadvantages to having it always enabled? Good question. >> + my @use_pathinfo = gitweb_get_feature('pathinfo'); > > Why not name those variables for better readability? > > + my ($use_pathinfo, $trailing_slash) = gitweb_get_feature('pathinfo'); Good suggestion.