From: Junio C Hamano Date: Tue, 08 Dec 2009 09:25:42 GMT Subject: What's cooking in git.git (Dec 2009, #03; Tue, 08) Message-ID: <7vmy1tg6ll.fsf@alter.siamese.dyndns.org> Here are the topics that have been cooking. Commits prefixed with '-' are only in 'pu' while commits prefixed with '+' are in 'next'. The ones marked with '.' do not appear in any of the integration branches, but I am still holding onto them. -------------------------------------------------- [New Topics] * bg/maint-add-all-doc (2009-12-07) 4 commits. - squash! rm documentation--also mention add-u where we mention commit-a - git-rm doc: Describe how to sync index & work tree - git-add/rm doc: Consistently back-quote - Documentation: 'git add -A' can remove files I didn't like the existing documentation for "add -u" myself (especially because I wrote the initial version) and this neatly fix it as well. * il/vcs-helper (2009-12-06) 8 commits - Remove special casing of http, https and ftp - Support remote archive from external protocol helpers - Support remote helpers implementing smart transports - Support taking over transports - Refactor git transport options parsing - Pass unknown protocols to external protocol handlers - Support mandatory capabilities - Add remote helper debug mode (this branch is related to sr/vcs-helper.) Under active discussion and review; another round expected. * jh/commit-status (2009-12-07) 1 commit - [test?] Add commit.status, --status, and --no-status * jk/maint-add-p-delete-fix (2009-12-08) 1 commit. (merged to 'next' on 2009-12-08 at 3c2c08a) + add-interactive: fix deletion of non-empty files Fixes a regression in 1.6.5.3. * mm/diag-path-in-treeish (2009-12-07) 1 commit - Detailed diagnosis when parsing an object name fails. * ns/rebase-auto-squash (2009-12-08) 1 commit - rebase -i --autosquash: auto-squash commits (this branch uses mh/rebase-fixup.) -------------------------------------------------- [Stalled] * je/send-email-no-subject (2009-08-05) 1 commit. (merged to 'next' on 2009-10-11 at 1b99c56) + send-email: confirm on empty mail subjects The existing tests cover the positive case (i.e. as long as the user says "yes" to the "do you really want to send this message that lacks subject", the message is sent) of this feature, but the feature itself needs its own test to verify the negative case (i.e. does it correctly stop if the user says "no"?) * jc/checkout-merge-base (2009-11-20) 2 commits - "rebase --onto A...B" replays history on the merge base between A and B - "checkout A...B" switches to the merge base between A and B I've been using the first one for a while myself but do not see many users want this (yet); the new feature is not urgent anyway. * tr/maint-merge-ours-clarification (2009-11-15) 1 commit (merged to 'next' on 2009-11-21 at fadaf7b) + rebase: refuse to rebase with -s ours I do not think we reached a concensus for solving conflicts between "give them rope" and "protect users from clearly meaningless combinations". The author obviously is for the latter (and I am inclined to agree); Dscho seems to think otherwise. * jc/fix-tree-walk (2009-10-22) 8 commits (merged to 'next' on 2009-10-22 at 10c0c8f) + Revert failed attempt since 353c5ee + read-tree --debug-unpack (merged to 'next' on 2009-10-11 at 0b058e2) + unpack-trees.c: look ahead in the index + unpack-trees.c: prepare for looking ahead in the index + Aggressive three-way merge: fix D/F case + traverse_trees(): handle D/F conflict case sanely + more D/F conflict tests + tests: move convenience regexp to match object names to test-lib.sh This has some stupid bugs and reverted from 'next' until I can fix it, but the "temporarily" turned out to be very loooong. Sigh. We won't have a proper fix in 1.6.6. * jc/grep-full-tree (2009-11-24) 1 commit. - grep: --full-tree The interaction with this option and pathspecs need to be worked out better. I _think_ "grep --full-tree -e pattern -- '*.h'" should find from all the header files in the tree, for example. -------------------------------------------------- [Cooking] * jh/notes (2009-12-07) 11 commits - Refactor notes concatenation into a flexible interface for combining notes - Notes API: Allow multiple concurrent notes trees with new struct notes_tree - Notes API: for_each_note(): Traverse the entire notes tree with a callback - Notes API: get_note(): Return the note annotating the given object - Notes API: add_note(): Add note objects to the internal notes tree structure - Notes API: init_notes(): Initialize the notes tree from the given notes ref - Notes API: get_commit_notes() -> format_note() + remove the commit restriction - Minor style fixes to notes.c - Add more testcases to test fast-import of notes - Rename t9301 to t9350, to make room for more fast-import tests - fast-import: Proper notes tree manipulation Rerolled and under discussion. * jn/maint-pull-rebase-error-message (2009-11-27) 1 commit. (merged to 'next' on 2009-12-03 at 2ced03c) + pull: clarify advice for the unconfigured error case Replaces old 'jn/rfc-pull-rebase-error-message' topic. * fc/opt-quiet-gc-reset (2009-12-02) 1 commit - General --quiet improvements * mv/commit-date (2009-12-03) 2 commits - Document date formats accepted by parse_date() - builtin-commit: add --date option * mh/rebase-fixup (2009-12-07) 2 commits - Add a command "fixup" to rebase --interactive - t3404: Use test_commit to set up test repository (this branch is used by ns/rebase-auto-squash.) Initial round of "fixup" action that is similar to "squash" action in "rebase -i" that excludes the commit log message from follow-up commits when composing the log message for the updated one. Expected is a further improvement to skip opening the editor if a pick is followed only by "fixup" and no "squash". * sr/gfi-options (2009-12-04) 7 commits - fast-import: add (non-)relative-marks feature - fast-import: allow for multiple --import-marks= arguments - fast-import: test the new option command - fast-import: add option command - fast-import: add feature command - fast-import: put marks reading in its own function - fast-import: put option parsing code in separate functions Rerolled. * ap/merge-backend-opts (2008-07-18) 6 commits - Document that merge strategies can now take their own options - Extend merge-subtree tests to test -Xsubtree=dir. - Make "subtree" part more orthogonal to the rest of merge-recursive. - Teach git-pull to pass -X