From: Junio C Hamano Date: Wed, 25 May 2011 19:36:35 GMT Subject: Re: [PATCH 1/2] gitweb: Refactor reading and parsing config file into read_config_file Message-ID: <7vmxia373w.fsf@alter.siamese.dyndns.org> In-Reply-To: <1306341328-11108-2-git-send-email-jnareb@gmail.com> Jakub Narebski writes: > Beside being obvious reduction of duplicated code, this is enables us > to easily call site-wide config file in per-installation config file. > > The actual update to documentation is left for next commit, because of > possible exclusive alternative (possible other next commit) of always > reading system-wide config file and relying on per-instalation config > file overriding system-wide defaults. > > Signed-off-by: Jakub Narebski As John acked this one and it looks obviously the right thing to do to me, I'll apply this one directly to "master". Thanks.